Our 2001 Toyota Camry lit up the “Check Engine” light a few months ago.  We initially made an appointment for service but then I did some research and realized it might be something I could repair myself.

To start, I used the OBD wire I had acquired when replacing the Audi’s air bag sensor and hooked it in to my laptop.  But I discovered that the VCDS-Lite software I used for the Audi didn’t work on the Camry.  It only works for cars that use the standard created by Volkswagen AG (“VAG” for short).  Oops.  Okay, new plan: I found software called “Car Port” that would work the Camry, at least to tell me what the error code was.  And it worked fine with the OBD wire I already head.

The error code was “P1135”.  Some digging showed that it was one of the two oxygen (AKA “O2”) sensors – the “upstream” sensor is the one related to P1135 and the “downstream” one would be a P1155 (according to a post at Stack Exchange).  And fortunately for me, the upstream sensor is about as conveniently located as it can get: right in the center front of the engine – it’s the thing right in front that draws your attention when you open the hood.  There’s a helpful diagram in a post at engine-codes.com.

I figured the next step, before buying a replacement part, was to see if I could remove the old one.  It looked like it might be rusted in place so there was a chance that just removing it was going to be a battle I couldn’t win on my own.  Apparently, there is such a thing as an oxygen sensor wrench that is special in allowing you to screw it in or out like a traditional socket wrench except it makes the accommodation for the permanently attached wire.  I didn’t have one of them nor did I want to buy one so I figured I’d remove the heat shield so I could get a traditional adjustable wrench at the base of the sensor.  I used a socket to “unscrew” the bolts holding the heat shield in place.  The word “unscrew” is in quotes because two of the bolts didn’t so much unscrew as shear off due to corrosion.  With the heat shield removed, it was pretty easy to get the wrench in and the oxygen sensor did come out without too much trouble.  And the electrical connection is simple to unclip.

While it’s possible that there was an engine problem that the sensor was correctly reporting, since the engine was running fine and since the O2 sensors do fail, a faulty O2 sensor was much more likely.  So I felt pretty good about identifying the problem and how to replace the sensor.  Now the only trick was getting the right replacement part.

I found the sensors listed on the web sites of both of my local auto parts stores, Auto Zone and Advance Auto Parts.  Merely because Advance is 30 seconds closer to me, I decided to shop there and punched in the appropriate info to their site to check for the part.  I found many matching sensors for the 2001 Camry.  There are three brands, there are ones with California emissions and those without, there are upstream and downstream, and then there are seemingly duplicates.  That’s 24 possible matches for where I thought there would only need to be one.  I narrowed the brand down, and was able to filter out the ones for California and the ones for downstream leaving only non-California, upstream, and the OEM brand Denso.  But it still left two that seemed identical.  Time to go to the store.

I gave the person at the counter the same info and she answered that the part I needed wasn’t actually in stock but was in a nearby store and if I wanted the store would add it to the shuttle that swaps parts between stores and it would be there in an hour – which was really faster than I could have driven to the other store and back anyway, so sure.  I paid for the part and returned home, did a few other things and then headed back to the store to pick up the part.  Before I left the store with the part, I opened it up and compared it to the part I had removed.  Yep, it’s a match.  And “only” $110.  While I was at the store, I also bought some replacement bolts that were an exact match for the ones that had sheared off – only a couple of dollars for them.  Not too bad if that’s the only money I spend on this repair.

Back home, I followed the directions that came with the sensor.  You have to apply a special heat sensitive anti-seize compound to the threads of the sensor and then you screw it in just like it came out.  Then all you have to do is clip in the electrical connection.  I said all you have to do is clip in the electrical connection.  What the hell?  The connector doesn’t fit.  Maybe if I push harder.  Nope.  Upon close inspection, the connector has 4 sides where some of them have lines and some of them don’t.  And my new sensor’s lines didn’t match the same pattern as the old one.  I didn’t pay much attention to that before and even if I had, I’m not sure I would have realized it made much difference.  But it does.  A little more Googling and it turned out the original I had removed from the car was a “2-wire” sensor while the seemingly duplicate that I got was a “4-wire” sensor.  (Even though both of them, in fact, had 4 wires on them.)

I called the store and explained the situation.  They looked up in the computer and told me they had the other version in stock.  Too bad that isn’t the one that came up in the computer first!  That would have meant one trip to the store instead of three!  Oh well.  I returned to the store and exchanged the sensor I had tried for the correct one.  I compared the lines on the sides and confirmed that the new one was an exact match on the connector to the original one.  I needed to pay an additional $40 for the exchange because the one that matched was that much more expensive.  (The parts store didn’t ding me for getting the part wrong since they understood that they were partly responsible for that.)

Back at home, this sensor screwed right in just as the last one did but this time the electrical connection was as simple as clipping it back in.  Now the heat shield was a pain.  The bolts that had sheared off had left the hole fully plugged with the permanently rusted in pieces.  So I had to drill them out.  I thought at first that I would start drilling and the the screw remnants would then come out.  It did not.  I had to drill a full new hole and even tap it (fortunately, I have metric taps!) for both of the bolts that had sheared off.  That took a lot of patience to drill those holes in that thick metal.  But finally, the heat shield could be screwed back on and it was secure.  The result looks like a professional repair.  Nice.

I turned on the car and was very disappointed to see the check engine light was still on.  I soon realized it was just an issue of the code being cached.  I hooked back up Car Port to clear the code.  No luck – Car Port doesn’t seem capable of doing that.  Bummer.  Eventually, I found instructions for clearing codes somewhere (I can’t remember the web site).  The easiest way for me turned out to be disconnecting the battery.  I popped the negative cable off the battery and set it to the side being sure that it couldn’t spring back into place and touch the battery terminal.  I waited about 15 minutes – probably 14 more than I needed to but I was chatting with the neighbor.  When I reconnected the cable, the alarm went off; this car has always had alarm problems like this so that was no surprise and pushing the disarm button the remote shut it up.  And happily when I turned the car on, the check engine light was off.  Hooray!

So I’ll rate this as a relatively easy do-it-yourself repair.  The cost of the part plus the bolts was only around $150.  Even if the bolts don’t shear off, I’d recommend getting replacement ones because you know that the old ones are going to be rusty and the bolts are cheap.  Unscrewing the heat shield isn’t too bad, if your bolts come out cleanly, though if you can do it with the special oxygen sensor tool and avoid removing the heat shield, you won’t need to worry about bolts at all.  Be sure to get an exact match to the sensor by comparing the markings on the connector at the store before you head home.  If you can figure out whether your sensor is 2-wire or 4-wire and buy the appropriate one in advance, you’ll increase the likelihood of getting a match.  Be prepared to kill the power to the car so you can clear the error code.  And even with needing to drill holes for bolts and multiple trips to the parts store, waiting for the (wrong) part to arrive, and all the research I’ve detailed here, the whole process took about 6 hours.  Assuming you can learn from my mistakes, it should take you well less time.

Leave a Reply

Human Verification *

All content Copyright © Katharsys LLC Created with Wordpress, Theme "Synergy" by Pagelines modified by Katharsys LLC