MythTV sound problems… again

| by Ken | in Technology No Comments »

My main MythTV system (AKA “backend”) is in my entertainment system rack in the old family room.  My office is merging into that room and I needed to move the system rack a bit to make room for additional furniture.  And the rack had a few things that were no longer in use (like ReplayTV [still mourning that]) and a bunch of wires that had been used for things and hadn’t been pulled out.  Also, my APC UPS had proven defective (what good is a UPS if you can’t rely on it) so I removed it but needed to rework some stuff to get in the new one.  For all of these reasons, it made sense to disassemble the whole entertainment system and rebuild it clean – figuratively and literally.  Lots of dust to vanquish.

I put it all back together meticulously tying cables together and running cables in layers so everything was neat.  Once I got to the point when it was time to power everything up, I hadn’t gotten the TV put back on top yet.  (That old Panasonic plasma weighs 250 pounds and I needed to make sure I only moved that when I was sure I was done.)  I wanted to give MythTV a chance to catch up on database activity since it had been off for the better part of a day and I didn’t need to see that happen.  I made sure I had the MythTV parts set up and connected before I powered it on and the attached the Comcast cable box and HD-PVR.  And When I was certain everything else was working, I hoisted the TV back in place and hooked up all the HDMI.  Then I could test out the whole setup.  Everything worked with the exception of two problems with MythTV: the network didn’t come up and I didn’t hear any sound.  The network problem turned out to be because my Panamax power protector doesn’t work with Gigabit so I’ve ordered a separate network protector and in the meantime, I have the network cable skipping surge protection which is how I had it before – easy resolution.  But the sound problem turned out to be a bear to resolve.

Continue reading »

Installing MacOS Guest in VirtualBox

| by Ken | in Technology No Comments »

I’ve experimented with VirtualBox before but today I had a legitimate work need to try out VirtualBox with a MacOS Guest. So I installed VirtualBox on my Windows 7 64-bit laptop and pulled out my Snow Leopard DVD and… it didn’t work. Nothing could be that easy, right?

I Googled for an hour or so looking for the trick but all the posts I found were about how to work with a drive image or a hacked install or to use special bootloaders that would function as a sort of handoff (such as the Empire EFI which is interesting since it touches on the Hackintosh concepts I’ve talked lots about in this blog). I eventually found the trick I needed at something called “LeaseWeb Labs” in a post titled “How to run OSX in a VM on VirtualBox“.
So here’s what I did:

Continue reading »

After some recent network improvements at the house, I discovered the new router was causing interference with my old phone system.  Rather than replace the phone system with a newer one that is both technologically better and feature poorer, I decided to stick with the current one and change what I could.

Figuring that the new router is only causing interference where the old one did not must be because it the signal is somehow stronger.  Fortunately, I’m running dd-wrt on my routers so I there’s more tweakability than with stock firmware.  And fortunately one of the things you can tweak is the “TX Power”.  The default value for TX Power for the 2.4 Ghz antenna was 71 (out of a reported 1000?  that doesn’t seem right).  I changed it to 60 and the warblyness in the cordless phone went away mostly.  I can still get interference if I walk to the router and touch the phone’s antenna to the router.  Since that isn’t something I need to do to use the phone normally, I think I’m good now.

I’ve been using the same cordless phone system for probably 15 years.  It is a Panasonic KX-TG2720 base with lots of handsets.  An important feature for me is that it has 2 lines.  We still have a landline for the “house” and I have a work line.  I use the speakerphone.  We have Comcast voicemail on both lines and the handsets are setup to show when there is new mail and you just push a button to listen to your messages.  The handsets also include speakerphone capabilities.  The range is fantastic and covers our whole house including basement and all of our yard which isn’t saying too much, but the point is it is exactly what we need.

A month ago I re-jiggered our home network and replaced one of the older routers with a new one.  Since then we’ve been having interference between our handsets and the WiFi.  Frankly, it’s surprising we haven’t had a problem before since the old phone system is a 2.4 Ghz system and of course, that’s the band that WiFi has been operating in for years.  (And while I’d love to disable the 2.4 Ghz antenna from the routers, I have too many devices that don’t work with the 5 Ghz band.)  The new router has been a problem, though, making the phone sound really warbly when anywhere on the first floor – i.e. close the new router.

Continue reading »

I’ve got that new tablet that I’ve been writing about, the Teclast X16, and I want to be able to “watch TV” on it.  No, not live TV (except for the occasional truly live event, I have little use for live TV) but shows that have been recorded on MythTV.  The shows are on the server and I could stream them from there using a MythTV Android client.  And that does work.  But if I can avoid needing a network connection, I’ll be better off and most importantly, then my TV can travel with me.

The “tPad” does communicate through Bluetooth and I could use a BT file transfer to load files to it.  But I really don’t want to struggle with those kinds of connections.  I could also do a USB transfer which skips the flakey BT connection but then I still have to worry about filling up the “drive”.  I’d rather use the SD card slot on the tPad to store the stuff to watch.  (Technically, it is a Micro SD and it is labeled as TF.  Since I’ll be using an SD adapter to write to it from the MythTV server, for the rest of this post I’ll just refer to it as an SD card.)  And rather than stuff in an empty card and then transfer stuff to the tPad and store it on the SD card, way easier to just put the SD card into my MythTV server and drop the files on the card there.  Sure, there’s an element of sneaker-net involved.  But this isn’t something I’m going to do daily and it really isn’t too much trouble to stuff a card into the front panel of the MythTV server.  Besides, this way, if the SD card fills up, I know I have enough TV to last me a good long while and don’t have to worry about breaking the tPad functionality by accidentally filling up the main “drive”.  The only real hard part was setting up MythTV to automate getting the recordings to the SD card.

Continue reading »

Teclast X16 Support Through GearBest

| by Ken | in Technology 5 Comments »

I bought my Teclast X16 Pro from Gear Best at the end of January.  I previously wrote about my initial thoughts on the device and my opinion hasn’t changed since.  I still think the device is pretty good overall.  But it still has serious battery issues and a WiFi problem.  The battery drains completely within 48 hours without using the device at all so it appears that the device never properly sleeps.  And the WiFi will only find 2.4 Ghz networks, not any 5 Ghz networks.  Over the last couple of months I’ve been trying to figure out what to do about these two issues.  And I’ve been keeping my eye on a third potential issue – that the screen occasionally flickers.

Continue reading »

Xfinity WiFi Trojan Horse

| by Ken | in Technology 3 Comments »

Have you noticed a WiFi network near your house with the name “xfinitywifi”?  Have you thought it interesting that the signal seemed to be as strong as your own network in your house?  If you are a Comcast network customer, it’s probably your own networking hardware offering you an alternate connection.  Comcast has their hardware default to a setup that provides a public access point for everyone under the name “xfinitywifi”.  Their idea is somewhat admirable: save the ordinary customer the trouble of configuring a guest network and at the same time, enable every customer of theirs able to access any Comcast WiFi network anywhere.

There are a few problems, though.  First is that you have to be a Comcast customer to use the guest network and I assume you don’t select your friends based on whether or not they use the same ISP as you.  Secondly, the sign in requires you to sign in to Comcast meaning you have to go through extra login with credentials that you hopefully remember every time you connect.  Third, any knucklehead with a Comcast account walking down the street can pause in front of your house and use your bandwidth.

I had seen xfinitywifi show up in a site survey and I concluded that it was my neighbors who hadn’t bothered to customize their SSID.  I replaced my cable modem as part of a network overhaul at my house and after I did so, I noticed a new and stronger xfinitywifi signal.  I was able to look at the network info and MAC address and figure out that that new network was coming from my hardware in addition to the private network.  (And I realized that while I was correct about the previous conclusion about the signal coming from my neighbors, I didn’t realize that I was effectively seeing two signals from each Comcast neighbor.)  Since I use my own routers, I set the Comcast cable modem to “bridge mode” which means it disables the wireless signal.  Except it actually leaves the xfinitywifi network active!  And there’s no way in the configuration pages to disable it.

The way you manage it, believe it or not, is through your Comcast account.  The easiest thing to do is to login to your Comcast account in your web browser.  Then open a new tab and paste in this URL:  https://customer.xfinity.com/WifiHotspot  Choose the “Disable” radio button and click Save.  So it’s pretty easy to do when you know where to go.  But who would have thought to do that?

I wonder why Comcast wants to have users control this behavior through their site.  Perhaps this is something they want to track and the settings in an individual cable modem are not things they can “see”?  Okay, so it isn’t really a Trojan Horse, since the public network packets that are sneaking through the cable modem that you let into your house aren’t going to escape the cable modem and unlock your front door.  But still, it seems that Comcast should be more upfront about what’s going on in the hardware they give you.

By now I’m sure you’ve ready my Pulitzer winning articles from Part 1 and Part 2?  Good, so I don’t need to repeat myself.  I’ll just summarize briefly: I was able to improve performance somewhat by replacing a router that seemed to be failing but I couldn’t improve any more on either of my two routers through either firmware updates or through antenna modifications.  The performance had plateaued but not as high as I thought it should have.  I thought I should be able to get better results and I wanted to try a bit more to improve things.

Continue reading »

WiFi Woes Part 2 – The Antennae

| by Ken | in Technology 1 Comment »

After having resolved some of the glitchy behavior I was seeing with my WiFi in my house, I wanted to go a little further and improve the signal strength.  The easiest way to do that seemed to be to mess around with the antennae on the two routers.

Continue reading »

WiFi Woes Part 1 – The Hardware

| by Ken | in Technology 2 Comments »

10 years ago, WiFi needs were simple. WiFi was a nice to have and I put the router in the attic of the house so the signal could reach all of the house. We have what is called a “two and a half” story house which means that we have two living floors plus an attic you can walk up to. It’s not a big house as each floor isn’t very large, but we do have a cube, more or less, where our height is about the same as the length and width, not including the attic and the basement. Therefore, the signal in the attic meant good coverage to the second floor below it where my office is and adequate coverage of the first floor. The basement had basically zero coverage but who cares – it’s a basement.

Shortly after we got some WiFi cameras and a dedicated camera viewer device that needed to work well on the first floor.  We also had people visiting with WiFi enabled laptops.  So the WiFi needs had escaped the office and were now everywhere in the house.  I added an older router to use as an access point in the first floor kitchen and that had our coverage working pretty well.

Now, of course, WiFi is all important.  The wife’s iPad, our two smartphones, my new tablet, all are primary devices now.  And everything we do on them needs the network.  And the WiFi setup I had setup years ago just wasn’t cutting it for these modern needs.  For years, the cameras and camera viewer have been dropping out frequently.  It’s frustrating, but hardly mission critical.  More recently, I noticed that when I am home and check my e-mail on my phone through WiFi, the e-mail has to wait about 1 minute for it to decide if can get messages and it frequently gives up.  On the other hand, if I leave the house and am only on the cell network, my e-mail zips right through in an instant.  That’s not the way it is supposed to work.  What good is WiFi if I’m better off with the cell network?

Continue reading »

All content Copyright © Katharsys LLC Created with Wordpress, Theme "Synergy" by Pagelines modified by Katharsys LLC